Forum pubblico/privato: Pubblico
Permessi di scrittura: Utenti registrati
Giorno: 28/05/2020, 08:45:51
Usare|Installare LC0 su Mac
Qualche anima pia mi aiuta ad usare|installare LC0 su Mac? oppure sapete anche solo indirizzarmi a qualche sito dove trovare maggiori info? pechè seguendo la procedura indicata sul sito ufficiale di LC0 alla fine dopo aver installato Homebrew e LC0 mi dà un errore ... insomma non ci ho capito na mazza probabilmente ... Grazie . Eros
Giorno: 25/11/2020, 08:29:08
Link sponsorizzati
Giorno: 28/05/2020, 17:29:45
Seguo con interesse.

DIMErodz83, se hai installato Homebrew significa che non c'è una versione nativa per Mac?

Dov'è il tutorial per installarlo su Mac?

ciao.gif
Lupin è l'autore de "Il Libro d'Oro degli Scacchi" www.chessgoldenbook.com
Giorno: 29/05/2020, 14:59:58
esattamente non c'è al momento . se vai su questa pagina

https://lczero.org/play/download/

e vai sulla seziona Mac vedrai che non c'è spiegato nulla solo l'indicazione di installare Homebrew e poi eseguire un comando di installazzione . io ho fatto tutto (credo bene ma non sono un programmatore o un ing informatico ) ma mi dà un errore alla fine dell'installazione di LC0 per cui non sò bene ... devo riprovare e se risolvo lo scrivo ... ma volevo sentire anche utenti ciao.gif
Giorno: 29/05/2020, 16:05:32
questo è l'errore - ERROR: Problem encountered: Lc0 requires a compiler supporting C++17, for example g++ v8.0, clang v5.0 or later (with C++17 stdlib) and Visual Studio 2017 or later.

inoltre :

Error: You are using macOS 10.10.
We (and Apple) do not provide support for this old version.
You will encounter build failures with some formulae.
Please create pull requests instead of asking for help on Homebrew's GitHub,
Discourse, Twitter or IRC. You are responsible for resolving any issues you
experience while you are running this old version.

per cui posso ipotizzare che se hai una versione di Mac osx più aggiornata della mia dovrebbe quanto meno installare tutto . poi per farlo funzionare non sò .
Giorno: 30/05/2020, 12:07:06
DIMErodz83,
a quanto scritto dovrebbe essere come dici tu: aggiornare il sistema operativo.
Ma a questo punto, visto e considerato che la versione nativa non esiste manco a pagarla, hai provato ad installare CrossOver, con ad esempio Fritz o una GUI compatibile come Arena, e poi installare LC0?

ciao.gif
Lupin è l'autore de "Il Libro d'Oro degli Scacchi" www.chessgoldenbook.com
Giorno: 30/05/2020, 12:10:41
Nella pagina che mi hai indicato c'è scritto: "The Homebrew package includes the lc0 engine and network 42850."

Quindi se anche riuscissi ad installare con Homebrew avresti comunque una rete vecchia di LC0, non so se ne valga la pena.
In tutti i due casi il tutto viene emulato, per cui...
Meglio provare con CrossOver, si perde qualcosa come prestazioni generali, ma perlomeno si ha l'ultima rete disponibile.
Lupin è l'autore de "Il Libro d'Oro degli Scacchi" www.chessgoldenbook.com